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What is a Workflow?
A HubSpot workflow is an automation tool that executes a series of actions, like sending emails 
or updating properties, triggered by user-defined criteria.

Simple use cases:
● Lead Nurturing: Sending a series of targeted 

emails to move leads through the sales funnel.
● Email Follow-ups: Triggering follow-up emails 

after a contact views a web page or downloads 
content.

● Internal Notifications: Alerting team members 
via Slack, SMS, or email about important 
customer actions.

● Task Creation: Generating tasks for sales reps to 
call leads or follow up on specific actions.

Complex use cases:
● Multi-Stage Lead Nurturing: Series of 

workflows that guide a lead through different 
stages of the buyer’s journey, with each stage 
triggering specific actions like sending 
educational content, scheduling calls, or updating 
lead scores.

● Sales Pipeline Automation: Move deals through 
various stages in the sales pipeline based on 
actions taken by leads, such as email 
engagement, website visits, or form submissions.

● Complex Lead Routing: Assign leads to sales 
reps based on multiple criteria, such as 
geographic location, company size, and industry, 
ensuring leads are handled by the most 
appropriate team member.

Please note: Using the Workflow tool requires either Marketing, Sales, Service, or 
Operations Hub Professional or Enterprise level subscription.
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Navigation

→

Automations > Workflows
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Workflow Index

View turned off workflows 
or workflows that  haven't 
executed any actions in 
the last 90 days. 

View workflows that need reviewed 
for errors or have previously been 
reviewed for errors.

Create custom properties and 
determine which property 
values must be filled when a 
workflow is created.

Access the health page to gauge your 
workflows’ status. Utilize the reports to 
dissect workflow efficiency, spotlighting 
problematic or dormant workflows.

Examine enrollment data and explore 
additional areas for enhancing 
automation. This can speed up the 
process of identifying opportunities to 
apply or refine automation strategies.
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Objects & Types
Objects

Default available [object]-based workflows:
● Contacts
● Companies
● Deals
● Conversations
● Subscriptions
● Payments
● Goals
● Users

Subscription specific [object]-based workflows:
● Quotes (Sales Hub Professional or Enterprise)
● Tickets (Service Hub Professional or Enterprise)
● Custom objects (Enterprise only)
● Feedback submissions (Service Hub Professional or 

Enterprise)
● Leads (Sales Hub Professional or Enterprise)

Types

From Scratch Start with a blank workflow

From Template Use a template built by HubSpot.
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Templates
Choosing a workflow template that resonates with your objectives can significantly enhance 
your automation strategies. These templates are not just about convenience; they’re a gateway 
to discovering a variety of automation possibilities that could transform the way you work.
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Editor
Automations > Workflows > Create Workflow > From Scratch

Choose your Object
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Enrollment Criteria

Types Examples

When an event occurs - objects will 
enroll when an event has happened. 

● Contact visits a specific page
● Companies property value changed
● Call is ended with a contact

When filter criteria is met - 
objects will enroll when a criteria is true.

● Contact  property is xyz value
● Company record is not a member of a list
● Deal amount is less than or equal to xyz value

Based on a schedule - objects will 
enroll based on on a specified calendar 
date or by using a date property.

● [Object] date property: Enroll a deal > once 
> 1 day after Close Date at 7pm. 

● Calendar date: Enroll contacts on a list for a 
future date at specified time to launch a drip 
campaign. 

Configure triggers for workflow enrollment to initiate automatic record 
inclusion once specific conditions are met or an event is completed. 

Please note: When configuring based on a schedule enrollment criteria, options 
for frequency of the trigger will depend on subscription. 
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Actions
Select the actions that your workflow will carry out on the enrolled records. These actions 
could include sending emails, generating new records, set property values, and more. 

Please note: Availability of certain actions may vary with each object-based workflow type.

→
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Delays

Types Examples

Calendar date - mm/dd/yyyy at HH:MM Delay enrolled records until 9/29/25 at 9am.

Date property - [object] date property at HH:MM Delay enrolled contact record until 2 days after 
Last Contacted property at 12pm.

Event occurrence - [object] date property Delay enrolled deal record until Deal Stage is 
any of Closed Won for 30 days. 

Set amount of time - days, minutes, seconds Delay enrolled ticket record for 4 days. 

Days of week - Monday - Sunday at HH:MM Delay enrolled contact record until Wednesday 
at 3pm.

Time of day - HH:MM Delay enrolled company until 5pm.

Workflow delays in HubSpot are used to space out actions within 
a workflow, allowing you to time your next actions.
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Branches
Implement branching logic within your HubSpot workflow to guide 
records along distinct paths determined by predefined conditions.

Types Examples

One property or action output Branch based on the deal stage property of 
enrolled deals; create a separate branch for 
each stage.

AND/OR logic Branch based on enrolled companies list 
membership and company owner is any of 
xyz user. 

Random distribution by 
percentage

Branch 50/50 on enrolled contacts. 
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Go to Workflow & Go to Action

Go to Workflow
Send the enrolled records from 
the current workflow to a 
different workflow.

Please note:  an enrolled record can 
only go to a workflow that matches 
the object type (e.g., deal records can 
only go to another deal-based 
workflow).

Go to Action
Allows you to consolidate if/then 
branches by connecting them. 

Please note: this action can only be 
added within branches. You can only select 
actions in a different branch. This is done 
to prevent loops.
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Communications
Actions

Enroll in a sequence - enroll contacts into a sequence
(Sales Hub and Service Hub Enterprise only)

Send Email - send an automated marketing email to enrolled contacts or 
associated contacts to the enrolled record.
(Marketing Hub and Service Hub Professional and Enterprise only)

Send in-app notification - send an in-app notification to specific users or 
teams.

Send an internal email notification - send an internal email notification 
to specific users or teams.

Send internal marketing emails - send an automated email to specific 
email addresses or a contact property that stores an email address.
(Marketing Hub Professional and Enterprise only)

Send WhatsApp message - send WhatsApp messages to contacts with 
a valid WhatsApp phone number. 
(Marketing Hub and Service Hub Professional and Enterprise only)

Unenroll from sequence - unenroll contacts from a sequence they are 
currently enrolled in.
(Sales Hub and Service Hub Enterprise only)

Assign conversation owner in a workflow - in conversation-based 
workflows, change the inbox and owner for a conversation.
(Services Hub and Operations Hub Professional  or Enterprise only)
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CRM
Action

Clear property value - clear a value in a property for the enrolled record, or a 
property in an associated record. 

Copy company property value - copy a company property value from the 
primary associated company of the enrolled contact. 

Copy property value - copy a property’s value on the enrolled record for a 
target property on the same record or an associated object records property.

Create record - create new records:
● Contacts
● Companies
● Deals
● Tickets (Service Hub Professional and Enterprise only) 
● Leads (Sales Hub Professional and Enterprise only)
● Custom objects (Enterprise only)

Create Salesforce task - create a Salesforce task; the contact owner or 
integration user will then receive a task in Salesforce associated with the 
enrolled contact.

Create task - create new tasks

Delete contact - delete enrolled contacts; contacts can be restored 
manually within 90 days of deletion.

Increase or Decrease property value - increase or decrease the value in 
a number type property of the enrolled record.

Manage communication subscription - set the subscription status of 
enrolled contacts and provide the legal basis for communicating with the 
contact. 

Rotate record to owner - assign enrolled records to users or teams 
equally. 
(Sales Hub and Service Hub Professional and Enterprise only)
Please note: Users must have a paid seat.

Set property value - set a property’s value on the enrolled record or an 
associated object records property.

Set Salesforce campaign - set a Salesforce campaign for the enrolled 
contact.
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Marketing
Action

Add to ads audience - add enrolled contacts to a new or existing ads 
audience. 
(Marketing Hub Professional and Enterprise) 

Add to static list - add enrolled contacts or companies to a static list. 

Remove from ads audience - remove enrolled contacts from an ads 
audience. 
(Marketing Hub Professional and Enterprise)
Please note: you can only choose from audiences that were created from a 
workflow. 

Remove from static list - remove enrolled contacts or companies from a 
static list.
(Marketing Hub Professional and Enterprise)

Set marketing contact status - set the marketing contact status of 
enrolled contacts. 

Please note: contacts can be set as marketing at any time, but will only update 
to non-marketing on the first of the following month or on your renewal date. 
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Data Ops
Action

Custom code - write and execute JavaScript in your workflow.  
(Operations Hub Professional and Enterprise only)

Format data - fix, format, and maintain CRM data. 
● Add a number
● Add an amount of time
● Calculate nth root of a number
● Capitalize first letter
● Change all characters to lowercase
● Change all characters to uppercase
● Change to title case
● Cut a character or several characters
● Divide a number
● Escape and URL encode
● Format date and time
● Get absolute value of a number
● Multiply by a number
● Remove HTML tags
● Replace characters
● Round a number
● Subtract an amount of time
● Test if a number is divisible
● Trim leading and trailing whitespace

(Operations Hub Professional and Enterprise only)

Send a webhook - send or retrieve information between HubSpot and other 
external tools. 

- POST request
- GET request

(Operations Hub and Professional and Enterprise only)
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Organization
Organization can help you ensure that your HubSpot workflows are clear and easy to navigate, which in turn can 
improve your overall automation strategies. Try the following:

● Use Naming Conventions: Establish clear naming conventions for your workflows to make them 
easily identifiable. This could include the use of prefixes or tags that indicate the workflow’s 
purpose.

● Implement Folders: Group related workflows into folders. This helps in categorizing them by 
function, team, or campaign, making it easier to locate and manage them.

● Regular Cleanup: Periodically review your workflows to remove or update those that are 
outdated or no longer in use. This prevents clutter and ensures that your workflows remain 
relevant.

● Leverage Workflow Views: Customize your workflow views to display the most pertinent 
information. You can filter workflows by various criteria such as status, type, or creator to 
streamline your view.
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Goals
In the creation of a contact-based workflows, establishing a goal can 
sharpen the workflow’s focus and enable you to track its effectiveness 
in engaging contacts. Once contacts achieve the set goal, they are 
automatically removed from the workflow, similar to how suppression 
lists function. 

Please note: that tracking the rate of goal achievement—goal conversion rates—is a 
feature exclusive to Marketing Hub Professional and Enterprise accounts. Additionally, 
when a contact meets your workflow goal and was sent a marketing email in the 
workflow, they will count towards the workflow's goal conversion rate.
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Action Sets
Action sets allow users to save and reuse a collection of workflow 
actions, streamlining the process of creating and managing workflows. 

Once created, action sets can be utilized by any user with workflow 
permissions in your account. 

Please note: action sets are specific to workflow object types; for instance, action sets 
created in contact-based workflows are only available for use in other contact-based 
workflows.
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Planning
The planning phase for your workflow strategy is crucial for its success. Please consider the following:

Define

What do you want to 
achieve with this 
workflow?

What is the desired 
outcome of the 
workflow?

What object will be 
enrolled into the 
workflow?

Build

What actions will be 
needed?

What assets will be 
needed (e.g., 
marketing emails)?

What enrollment 
triggers?

Test

Use test records to 
manually enroll into 
the workflow

Test enrollment 
criteria with an 
existing record.

What are the results 
of your testing? Any 
improvements 
needed?

Review

Confirm workflow 
settings

Should records 
re-enroll into the 
workflow?

Confirm the workflow 
has a name and 
description
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Testing Enrollment
Testing Enrollment Criteria:
● Go to Automations > Workflows 
● Select a workflow and click on Enrollment triggers.
● Use the Test [object] option to check if a record meets the criteria.
● The test will show if the record is eligible for enrollment.

Simulating Workflow Actions:
● Within the workflow, click Test in the upper right.
● Choose a record to preview and opt to receive email simulations if 

desired.
● Click Test to simulate the workflow journey for the record.
● Review the outcomes and branch paths without executing real 

actions.

→

→
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Avoid Common Pitfalls
Editing active workflows - Being aware of the 
consequences when editing an active workflow ensures that 
the results and performance align with your expectations.

Enrollment triggers: editing the enrollment triggers in an active workflow 
doesn’t automatically unenroll existing records who fail to meet the new 
criteria. 

Delays: shortening an existing delay may affect records already in queue; this 
may cause the record to exit the delay, depending on the type of delay being 
used. Extending a delay means records will encounter the increased wait time.

Adding or removing actions: adding or removing an action will not affect 
records past that point; they will not retroactively complete or reverse the 
action. 

Over complicated workflows - Attempting to achieve multiple 
objectives within a single workflow can lead to intricate branching. 
This not only makes logical execution tough but also increases the 
likelihood of mistakes.

Strategic use of branching is beneficial in complex workflows. They can make 
your automation seem foolproof and interconnected.

However, the complexity of such workflows can become a hindrance. Overly 
complicated workflows are difficult to troubleshoot and comprehend during 
audits, particularly as time passes or if the creator leaves the organization. 

Failing to optimize and review - workflows are designed 
to function autonomously, but they require regular evaluations 
to ensure efficiency.

It’s advisable to conduct a thorough review of your workflows on a schedule 
that works for your business. This proactive approach helps identify and rectify 
any inefficiencies, keeping your processes streamlined and productive.
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Enrollment
Why did this record not enroll?
● Go to Automations > Workflows.
● Click on the workflow you’re reviewing..
● Go to Help > Troubleshoot enrollment option.
● Choose the record you believe should have been enrolled from the 

dropdown.
● Specify the expected enrollment period using the Date range and 

Time range options.
● Execute the enrollment checks to understand the reasons behind the 

enrollment status.
● Expand the checks for more information and view the workflows 

configuration at the time of enrollment.

Please note: this tool only supports property, list, and form submission 
filters for troubleshooting.

Why did this record enroll?
● Go to Automations > Workflows.
● Click on the workflow you’re reviewing.
● Click on View > Enrollment history.
● Hover over an enrollment event and select Why did this enroll? to 

analyze the cause.
● In the right panel, review the enrollment date, time, and rationale, 

along with property state details if applicable.
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Action Logs: Errors
● Go to Automations > Workflows.
● Click on the workflow you’re reviewing.
● Go to View > Action logs.
● Add a filter for Event: Errors

→

Click here for a complete list of errors, what they mean, and how to resolve.

https://knowledge.hubspot.com/workflows/troubleshoot-common-workflow-errors#:~:text=Error%20log%20events.-,error%20logs,-After%20updating%20your

